lundi 20 avril 2015

Get libpq runtime version (from libpqxx)

In the libpqxx reference I can read sometimes stuff that is limited to the underlying libpq version ("Requires libpq version from PostgreSQL 7.4 or better. ") like here.

Now the question(s): (1) How to obtain the libpq version used in the current program (using libpqxx)? (2) As far as I found out, libpqxx not necessarily need to be recompiled when moving forward to a new libpq release. Replacing the old libpq.dll covers (often) new technologies, like ssl compression in my case. That is why I am thinking the libpq version shall be received on runtime.

Aucun commentaire:

Enregistrer un commentaire